台灣最大程式設計社群網站
線上人數
1149
 
會員總數:246740
討論主題:190153
歡迎您免費加入會員
討論區列表 >> Android APP 開發 >> 有關新改版的開發工具如何編譯舊專案的問題
[]  
[我要回覆]
回應主題 加入我的關注話題 檢舉此篇討論 將提問者加入個人黑名單
有關新改版的開發工具如何編譯舊專案的問題
價值 : 50 QP  點閱數:2290 回應數:20
樓主

小蝸
初學者
70 46
647 67
發送站內信

如題,請問大大們,是否是因為我用新版本的關係 我開啟舊專案範例無法用模擬器來編譯, 希望有高手大大能幫幫我>\\\<
本篇文章發表於2012-09-03 18:37
1樓
回應

香帥
檢舉此回應
你的模擬器可以製作1.5,1.6...2.0....2.x...
配合您的新版本,您要製作適當的模擬器才可以呀
您若要相容性高,從低版的先測試,一直到高版的,太低的版本,新指令當然有些無法適用
都測完後,您才可以公布您的軟體是要多少以上版本才可以執行,這樣大家在下載軟體時就先知道他手機版本能不能執行您的軟體.
本篇文章回覆於2012-09-03 19:10
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
2樓
作者回應

小蝸
檢舉此回應
您好我新增模擬器的時候 (Window -> AVD manager) 裡面的 Target 只有 : Android4.1-API Level 16 這個選項,新增出來的模擬器沒辦法編譯參考書內附的光碟的專案。 請問該如何解決?? 如何測試呢??
本篇文章回覆於2012-09-03 19:33
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
3樓
回應

香帥
檢舉此回應
在eclipse按window->ADV Manager->New
去增加各版本的模擬器
本篇文章回覆於2012-09-03 19:52
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
4樓
作者回應

小蝸
檢舉此回應
對 我就是按裡面的New 但是他的 Target 只有 Android4.1-API Level 16 這個版本 怎麼辦呢?? 這個版本不是最新的ㄇ?? 為什麼沒辦法編譯舊版本的範例呢??
本篇文章回覆於2012-09-03 19:58
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
5樓
回應

香帥
檢舉此回應
補充按了後會產生如下右邊的圖

您在name輸入 適當名稱我習慣用 avdx.x如左圖(哈現在才發現有些我輸入顛倒成adv,不過都沒關係隨您高興取名子)
然後按target選適當的 選您書上的版本
其他欄位輸入後
按Create AVD
這樣就ok
本篇文章回覆於2012-09-03 20:00
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
6樓
回應

香帥
檢舉此回應
我的target是從1.5到4.1
本篇文章回覆於2012-09-03 20:04
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
7樓
作者回應

小蝸
檢舉此回應
但我的Target 只有一個選項 請問怎麼跟您一樣有很多選項呢??
本篇文章回覆於2012-09-03 20:06
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
8樓
回應

香帥
檢舉此回應
那表示您android sdk沒有安裝好
我下載的是這個
android_installer_r20.0.3-windows.exe
檔案長度68,844k
本篇文章回覆於2012-09-03 20:13
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
9樓
回應

香帥
檢舉此回應
下載頁面在
http://developer.android.com/sdk/index.html
再按右邊的
Installing the SDK.
這樣就可以了
本篇文章回覆於2012-09-03 20:17
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
10樓
作者回應

小蝸
檢舉此回應
那請問香帥大哥,安裝時要怎麼安裝,目錄選哪裡呢??
本篇文章回覆於2012-09-03 20:19
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
11樓
回應

香帥
檢舉此回應
我沒有改我按照他的預設
C:\Users\user\AppData\Local\Android\android-sdk
他安裝在這
每台電腦都不大一樣,不必改它的預設目錄
本篇文章回覆於2012-09-03 20:23
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
12樓
作者回應

小蝸
檢舉此回應

請問香帥大哥 我把原本的JDK移除之後 重新安裝到C槽 本來是在D槽 我開啟Ecilpse就出現這個錯誤了 請問大哥能幫幫我ㄇ><
本篇文章回覆於2012-09-03 20:59
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
13樓
回應

香帥
檢舉此回應
andriod sdk安裝前會檢查java是否安裝妥當,現在找不到的錯誤出現,那要再重新安裝java,您的安裝檔案還在吧,若不在又要去下載來安裝
本篇文章回覆於2012-09-03 21:08
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
14樓
作者回應

小蝸
檢舉此回應
好的 我試試看^^
本篇文章回覆於2012-09-03 21:10
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
15樓
作者回應

小蝸
檢舉此回應
請問香帥大哥能教我 "怎麼判斷專案的版本"呢??
本篇文章回覆於2012-09-03 21:11
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
   

回覆
如要回應,請先登入.