台灣最大程式設計社群網站
線上人數
1926
 
會員總數:246570
討論主題:190029
歡迎您免費加入會員
討論區列表 >> Linux / Unix >> 安裝php擴展庫發生Error: Missing Dependency
[]  
[我要回覆]
1
回應主題 加入我的關注話題 檢舉此篇討論 將提問者加入個人黑名單
安裝php擴展庫發生Error: Missing Dependency
價值 : 50 QP  點閱數:1033 回應數:1
樓主

watmoon
門外漢
0 17
437 34
發送站內信

小弟安裝php-xml 跑出Error: Missing Dependency,如下
php-xml-5.1.6-3.el4s1.10.i386 from /php-xml-5.1.6-3.el4s1.10.i386 has depsolving problems
--> Missing Dependency: php-common = 5.1.6-3.el4s1.10 is needed by package php-xml-5.1.6-3.el4s1.10.i386 (/php-xml-5.1.6-3.el4s1.10.i386)
Error: Missing Dependency: php-common = 5.1.6-3.el4s1.10 is needed by package php-xml-5.1.6-3.el4s1.10.i386 (/php-xml-5.1.6-3.el4s1.10.i386)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
請問各位前輩 問題是出在哪裡呢 ??




本篇文章發表於2015-06-02 18:13
1樓
回應

towns
捐贈 VP 給 towns 檢舉此回應
這個看起來是相依性問題,他是說安裝php-xml-5.1.6-3.el4s1.10.i386,需要php-common = 5.1.6-3.el4s1.10

你可以確認一下
1. 是否已安裝php-common-5.1.6-3.el4s1.10
2. 如果已安裝版本是否為5.1.6-3.el4s1.10

另外,直接使用yum安裝,就不會有相依性問題了
本篇文章回覆於2015-07-03 16:50
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
   
1

回覆
如要回應,請先登入.